Поле объекта не обнаружено 1С

Проблема с которой встречаются пользователи 1С:Підприємство — «Ошибка: Поле объекта не обнаружено”, чаще всего всплывает при запуске. Данная проблема приносит неудобство и тормозит рабочий процесс. Многие пользователи, как показывают опросы, не знают как быстро и самостоятельно решить эту проблему. Давайте рассмотрим эффективные рекомендации.

1с ошибка поле объекта не обнаружено

В установках 1С:Підприємство к каждому объекту присвоено собственное поле. Проанализировав такую ошибку с позиции программиста, можно сделать вывод: проблема появляется в том случае, когда программа обращается к не заданному в объекте полю. Оценив проблему с позиции пользователей, ошибка в 1С:Підприємство заключается в том, что программа не может найти заданный пользователем атрибут.

Ошибка 1С:Підприємство, как правило, появляется в трех ситуациях:

  • при входе в программу;
  • во время заполнения формы;
  • перед заполнением шаблона.

Этот список может продолжаться, но методы устранения сбоя полностью зависят от деталей некорректного отображения страниц.

Аутентификация

поле объекта не обнаружено как исправить

В свежих обновлениях 1С:Підприємство вход можно осуществить через OpenID. Эта новая опция позволяет упростить вход после того, как соединение было прервано.

Вы можете устранить проблему несколькими способами:

  • cделайте автоматическое обновление 1С:Підприємство платформу до самого свежего релиза (обновление вы найдете на официальном сайте 1С:Підприємство);
  • если не помогает, то нужен программист 1С:Підприємство

Как устранить проблему без использования обновления:

  • пропуск проверки внутри программы;
  • самостоятельное изменение правил обмена.
  • обратиться к программисту.

Специалисты все же рекомендуют при первой же возможности обновлять программу. Также одна из частых причин возникновения ошибки — это запуск старой версии во время ее обновления.

Склад

Причина: данные в документе указаны, к примеру, посередине таблицы, а должны располагаться в шапке:

  • настройте останову в точке ошибки;
  • в конфигураторе обязательно проверьте правильность внесенных данных.

Префикс Весового Товара

Префикс Весового Товара

Варианты устранения проблемы:

  • установите код для всех весовых товаров;
  • для кодов настройте шаблон (раздел «Настройки оборудования”).

Строка Поиска

  • внимательно проверьте код, возможно проблема возникла в перечислении, что говорит о неправильно заданном соответствии или о его отсутствии;
  • загрузите другую обработку конвертации.

Контрагент

Вы можете устранить данную ошибку, если включите в настройках «Независимое ведение партнеров и контрагентов”. Для того, чтобы перейти в это меню настроек, зайдите в «Администрирование”, а затем в «CRM и продажи”.

Рассматриваемая нами ошибка, часто возникает в новых релизах программы во время внедрения новых программных механизмов. В большинстве случаев, проблема решается сама собой во время выхода нового релиза. Чтобы не дожидаться нового релиза, не забывайте сохранять резервные копии. Это вернет вас к предыдущей версии. Эту опцию можно использовать при любых ситуациях, когда всплывает ошибка 1С:Підприємство.

Специалисты 1С:Підприємство дают еще несколько общих рекомендаций на тему того, что делать, если пользователь сталкивается с ошибками отображения функционала программы:

  1. Необходимо очистить конфигурацию от устаревшей и ненужной информации. В меню «Проверка конфигурации» установите флажок «Проверка логической целостности конфигурации». Программа самостоятельно удалит некорректную информацию.
  2. Для тех, чья конфигурация находится на поддержке, специалисты рекомендуют осуществлять тщательную проверку конфигурации поставщика. Чтобы провести проверку, загрузите конфигурацию поставщика в новую базу и повторите первый пункт.

Существует и некий алгоритм действий для устранения ошибок, который базируется чисто на технических моментах:

  1. Нужно выключить все фоновые задачи активных баз.
  2. Перезагрузить сервер.
  3. Сделать бэкап средствами sql.
  4. Снять базу с поддержки и выгрузить cf.

Сделал как в статье http://www.uasoft.com.ua/content/articles/315/
с поправкой на свою задачу.
Подключил через Сервис-> Дополнительные отчеты и обработки -> Доп. внешние печатные формы.
В докум. Счет заказа покупателя появилась соответсвующая кнопка. Но появляется ошибка
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (СсылкаНаОбъект)
В конфигураторе за это отвечает код
Функция НапечататьВнешнююФорму(Ссылка, ИсточникМакета) Экспорт
Перем ДополнительныеПараметры;
ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.Принадлежность.ХранилищеВнешнейОбработки.Получить();
// Получить дополнительные параметры внешней обработки
ИсточникМакета.Свойство(«ДополнительныеПараметрыОбработки», ДополнительныеПараметры);
Если ДвоичныеДанные = Неопределено Тогда
ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.ХранилищеВнешнейОбработки.Получить();
КонецЕсли;
Если ДвоичныеДанные = Неопределено Тогда
Возврат Неопределено;
КонецЕсли;
ТабДокумент = Неопределено;
ИмяФайла = ПолучитьИмяВременногоФайла(«epf»);
Попытка
ДвоичныеДанные.Записать(ИмяФайла);
Обработка = ВнешниеОбработки.Создать(ИмяФайла);
// здесь появляеся ошибка и перепрыгивает в конец
Обработка.СсылкаНаОбъект = Ссылка;
// Передать внешней обработке дополнительные параметры
Если ДополнительныеПараметры <> Неопределено Тогда
// Если у внешней обработки есть реквизит для дополнительных параметров, присвоить ему значение
Если НЕ Обработка.Метаданные().Реквизиты.Найти(«ДополнительныеПараметры») = Неопределено Тогда
Обработка.ДополнительныеПараметры = ДополнительныеПараметры;
КонецЕсли;
КонецЕсли;
ТабДокумент = Обработка.Печать();
УдалитьФайлы(ИмяФайла);
Исключение
ОбщегоНазначения.СообщитьОбОшибке(ОписаниеОшибки(),, «Не удалось сформировать внешнюю печатную форму!»);
КонецПопытки;
Возврат ТабДокумент;
КонецФункции

Технологическая платформа 1С:Предприятие и прикладные решения, созданные с ее помощью, постоянно совершенствуются: устанавливаются типовые обновления, программисты расширяют функционал конфигурации, осуществляется переход на новые версии платформы.

После выполнения подобных действий пользователю в процессе работы может быть выдана ошибка в 1С Поле объекта не обнаружено. Для ее устранения рассматривают обстоятельства возникновения сбоя, а затем выбирают вариант решения проблемы с ошибкой.

Рассмотрим примеры в конфигурации 1С 8.3 Бухгалтерия.

Причины и решения

Ошибка Поле объекта не обнаружено в 1С заключаются в неверном построении конфигурации, когда элемент справочника/документа/регистра или сами эти объекты целиком отсутствуют в открываемой форме. При программном обращении к полям таких объектов происходит сбой.

image002

При отлаженной работе конфигурации возникновение подобной ошибки маловероятно. Чаще всего она появляется:

  • после обновления программы;
  • при установке новой версии платформы;
  • из-за устаревшего кэша;
  • только у некоторых пользователей;
  • при внесении изменений в конфигурацию.

Найти ее с помощью встроенного в функционал конфигуратора механизма Тестирование и исправление не получится, т. к. сам объект в структуре конфигурации есть, иначе программа вывела бы сообщение с текстом «Объект не найден».

Ошибка после обновления конфигурации

Почти всегда типовые конфигурации после установки на рабочие компьютеры сотрудников продолжают находиться на поддержке разработчиков программы 1С. Обновления появляются примерно раз в месяц. Если автоматическая загрузка новых изменений не включена, то после запуска 1С будет предлагать пользователю обновить версию самостоятельно.

image004

Что же делать, если после установки обновления возникла ошибка в 1С 8.3 Поле объекта не обнаружено?

  • восстановить базу данных из последней резервной копии;

Настоятельно рекомендуется, прежде чем загружать и устанавливать обновления, делать резервную копию информационной базы на случай непредвиденных обстоятельств, а также периодически создавать резервную копию: раз в несколько дней. Резервная копия хранит не только данные, внесенные пользователем, но и ее программную составляющую. Поэтому при восстановлении конфигурация будет иметь старую структуру без внесенных обновлением изменений.

План действий:

  • проверить повторение ошибки в загруженной копии:
    • если сбой не устранился, следует рассмотреть другие причины его возникновения;
    • если ошибка больше не выходит, программа работает нормально, значит, источником было обновление, об ошибке можно написать в интернет-поддержку разработчикам 1С: Администрирование — Интернет-поддержка и сервисы — Настройки Интернет-поддержки.

image006

Для быстрого выявления причин сбоев программы, связанных с обновлением, рекомендуют не включать автоматическую загрузку новых версий, а делать это вручную: так будет проще установить зависимость появившейся ошибки от обновления. Для отключения функции откройте Администрирование — Интернет-поддержка и сервисы — Обновление версий программы — Обновление программы.

Опытные пользователи 1С советуют не ставить новые релизы сразу после их появления, а повременить 5-7 дней. Если в версии присутствуют ошибки, разработчики их исправят и выложат новое обновление.

Ошибка после обновления платформы

Последовательность действия по устранению сбоя аналогична пункту с установкой новой версии конфигурации.

Запустите базу на старой платформе, изменив версию в настройках.

image008image010

При повторении ошибки обратитесь в службу поддержки и ожидайте выхода исправлений.

Устаревший кэш

Кэш-память программы — это место, где сохраняются объекты, часто вызываемые пользователем из базы данных, чтобы не искать и читать их заново на сервере при повторном обращении к ним. В процессе работы в кэше скапливается множество записей, и некоторые из них могут быть устаревшими. Ошибка Поле объекта не обнаружено в 1С возникает при обращении к старым записям, хранящим информацию об элементе, которого больше нет. Для устранения почистите кэш-память:

  • откройте папку 1cv8 в каталоге пользователя: C:\Users\\AppData\Roaming\1C\1cv8;
  • удалите папки кэша, они имеют длинные имена, содержащие буквы, цифры, символы.

image012

Перед чисткой рекомендуется закрыть 1С, иначе часть файлов будет заблокирована программой.

Ошибка выдается некоторым пользователям

Когда сбой возникает при построении отчетности, выполнении обработки, открытии журналов или форм выборки у некоторых сотрудников, возможно, причина — в пользовательских настройках форм и списков. Редактирование внешнего вида 1С, производимое пользователями, записываются в Хранилище настроек. Среди изменений может присутствовать поле, элемент, которое было упразднено в программе. При открытии объекта из памяти от лица пользователя идет обращение к хранилищу, чтобы загрузить сохраненные пользовательские настройки, и, не найдя нужного поля, выдается сообщение об ошибке.

Для устранения сбоя очистите Хранилище настроек пользователя:

  • зайдите в систему под администратором;
  • перейдите Администрирование — Настройка пользователей и прав — Персональные настройки пользователей — Очистка настроек;image014
  • в окне Очистка настроек пользователей отметьте флаг У выбранных пользователей и перейдите по ссылке Выбрать;
    image016
  • отметьте пользователей и нажмите кнопку Выбрать;
    image018
  • в окне Очистка настроек пользователей отразится количество выбранных пользователей, нажмите Очистить и закрыть.

Произойдет полное удаление всех настроек, которое пользователь когда-либо делал, даже если эти настройки не связаны с ошибкой. Для точечной очистки хранилища по отдельным объектам:

  • перейдите по ссылке Настройки пользователей;image020
  • для просмотра сохраненных настроек конкретного пользователя выберите его в одноименном поле;image022
  • найдите объект, где происходит ошибка, и удалите все его настройки по очереди кнопкой Очистить.image024

Оформление программы, справочников, журналов, документов, форм выбора находятся на вкладке Внешний вид. Если сбой происходит при формировании отчета, объект следует искать на вкладке Настройки отчетов. В Прочих хранятся настройки печати и быстрого доступа к данным.

После редактирования конфигурации

Если ошибка возникла после доработки программы:

  • откройте конфигуратор;
    image026
  • запустите приложение в режиме отладки Отладка — Начать отладку;
    image028
  • выполните в пользовательском режиме действия, приводящие к возникновению ошибки;
  • нажмите кнопку Подробно и проанализируйте текст модуля для выяснения, где происходит сбой:image030 image032
    • на первом месте дублируется сообщение из окна ошибки, в скобках указано отсутствующее на форме поле;
    • в фигурных скобках сообщается путь к месту ошибки и номер строки: {Документ.СчетНаОплатуПокупателю.Форма.ФормаДокумента.Форма(1316)}:
      • объект конфигурации — Документ;
      • наименование объекта — СчетНаОплатуПокупателю;
      • сбой произошел в Форме с именем ФормаДокумента;
      • ошибка в строке 1316;
    • далее перечисляются кусок из кода, процедуры и функции, где для выполнения требовался недостающий элемент;
  • перейдите в конфигуратор по одноименной кнопке, в открывшемся окне курсор автоматически установится на строку с ошибкой;
    image034
  • решить проблему можно двумя способами, выбор будет зависеть от поля, из-за которого происходит сбой:
    • оно не должно присутствовать на форме — закомментируйте строки кода, в которых идет обращение к элементу, добавив два слеша в начале строки;image036
    • поле необходимо на форме:
      • перейдите на вкладку Форма;
      • в разделе Элементы попытайтесь найти поле из ошибки, возможно, допущена опечатка в наименовании;image038
      • если похожих по имени элементов нет, отыщите его в разделе Реквизиты и перетащите в окно Элементы.image040

Устранение ошибок после редактирования типовых конфигураций следует поручать профессиональным программистам, т. к. вмешательство в программный код может привести к сбою всей системы.

Отличие от ошибки «Объект не найден»

Ошибка не отображается во всплывающем окне, а прописывается в полях формы документов, справочников, отчетах. Она означает, что запись, которая ранее присутствовала в базе данных, была удалена пользователем, который это не учел, и в программе на эти записи ссылаются другие объекты.

Поэтому везде, где ранее был указан исключенный компонент или его часть, будет высвечиваться надпись «Объект не найден ()». Подобное может произойти, только если у пользователя есть права на прямое удаление объектов, без предварительной пометки на удаление.

image042

Причин возникновения ошибки Поле объекта не обнаружено несколько, и не всегда сбой удается вовремя обнаружить и устранить. В некоторых случаях пользователи программы 1С могут попытаться решить проблему самостоятельно. Но если ни один из способов не помог, то оптимальным вариантом будет обращение к опытному программисту 1С.

Поставьте вашу оценку этой статье:

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд

Добавить комментарий