Ошибка метода контекста

Вы помните пользователя, которого создали?
Возможно, Вы просто случайно выставили галочку «Не показывать в списке”.
Тогда Вы можете прямо в поле логина набрать это имя пользователя и нажать на ввод. Имя должно быть 100% правильно введено (пробелов лишних не должно быть, все буквы и цифры на своем месте).
Если дело в этом – Вы войдете в программу.
Но меня настораживает факт, что никаких прав не назначалось. Как же так?
Если это единственный пользователь, то программа при входе анализирует что ему доступно в программе, а что нет. Даже для прав чтения, т.е. только для просмотра данных требуется задать соответствующие права!
Без прав пользователей быть НЕ ДОЛЖНО!

Но если кто-то создал Вам этого пользователя в пользовательским режиме, то, вероятно, кто-то зашел туда уже под каким-то логином. Обычно, типовой логин Администратор. Если ничего не меняли, попробуйте войти под ним (без пароля).
Если не получится, то Вам нужно поискать на сайте Инфостарт обработку для чтения логинов и паролей в программе 8.3, чтобы разобраться, есть ли права, с которыми можно будет войти.

Или отдать базу специалисту 1С. Он откроет базу и создаст пользователя правильно.

Договор=РеквизитФормыВЗначение("Объект").ПолучитьМакет("Договор"); // Получить объект из макета. MSWord = Договор.Получить(); Попытка Документ = MSWord.Application.Documents(1); Документ.Activate(); // Получить объект, который будем использовать для поиска и замены. Замена = Документ.Content.Find; // Заменить заранее определенные ключевые конструкции на требуемый текст. Если MSWord.Bookmarks.Exists("Таблица1") Тогда //Выделяем обязательную закладку начала таблицы MSWord.Bookmarks("Таблица1").Select(); //Перемещаемся вниз, выделяем строку таблицы и копируем ее в буфер обмена MSWord.Application.Selection.MoveDown(); MSWord.Application.Selection.SelectRow(); MSWord.Application.Selection.Copy(); Для Каждого ТекСтр ИЗ Объект.Счет Цикл Товар1=СокрЛП(ТекСтр.ПолноеНаименование); Цена1=СокрЛП(ТекСтр.Цена); //Заменяем значения MSWord.Application.Selection.Find.Execute("Номер" ,,,,,,,,,Товар1,2); MSWord.Application.Selection.Find.Execute("Цена" ,,,,,,,,,Цена1,2); //Последний параметр поиска пустой //Перемещаемся вниз, вставляем из буфера обмена строку MSWord.Application.Selection.MoveDown(); MSWord.Application.Selection.Paste(); //Перемещаемся вверх и выделяем строку для замены значений MSWord.Application.Selection.MoveUp(); MSWord.Application.Selection.SelectRow(); КонецЦикла; //Вырезаем лишнюю строку MSWord.Application.Selection.Cut(); //Скрываем обязательную закладку начала таблицы MSWord.Bookmarks("Таблица1").Select(); MSWord.Application.Selection.TypeText(" "); КонецЕсли; // Делаем видимым приложение и активизируем его. MSWord.Application.Visible = Истина; MSWord.Activate(); Исключение // Если произойдет ошибка, выводятся данные об ошибке, и объект закрывается. Сообщение = Новый СообщениеПользователю(); Сообщение.Текст = ОписаниеОшибки(); Сообщение.Сообщить(); MSWord.Application.Quit(); КонецПопытки; КонецПроцедуры //Да-да-да код скомунизден

Добавить комментарий